'Clear List' doesn't work unless a 0.1ms 'Pause' is added

I have a simple workflow on a button inside a Table Element (still under BETA) that:

  1. Clears a list of text items.
  2. Then adds 1 new text item.

When run in Real Time the list clears, then reappears with the new item added.
When I run it in Step Time the list clears properly as it should.

I figured that the ‘clear list’ was not able to complete its task before the the ‘add new item’ kicked in.
So I added a ‘Pause before next action’ of 0.1 ms after the ‘clear list’ but before the ‘add item’. It worked.

Why is this pause needed? Maybe because there is an inherent ‘animation fade’ on the button which causes the ‘clear list’ to not be completed in real time. (I’ll test that by removing the animation).

I have found this before and cured it in the same way.

A bit granular but it may help folk who have a similar problem.

I tested removing the inherent animation and then removed the 0.1ms Pause but this didn’t work.
So currently the ‘Pause before next action’ is still needed.

Once you are using the Add Item action, is the goal of this to then display just a single item? If not, then no need to do a clear list first. But if you do, then perhaps you can have a conditional trigger that is ‘when table list is empty’ and have that run the action to ‘add item’

Sort of. This workflow is to change Admin roles.

If a User is elevated to Main Admin from a lower admin role then their other roles are cleared (in the list) and the Main Admin role is the one that shows. I’ll take a look to see if I can use ‘when table list is empty’.

It’s odd that when I ran the workflow step-by-step it worked but not when I ran in real time. It does make me think there’s a lag somewhere.

Thanks for your thoughts, I’ll take a look at that though.

This topic was automatically closed after 70 days. New replies are no longer allowed.