Connecting to Microsoft SQL Azure

I am trying to connect to my SQL Azure database from Database Connector. I put in the connection string
but it seems to time-out with it saying “Current Fiber Times out after 65000ms”. I connect successfully from my local management studio so it can’t be the Azure portal. The only thing it can be is query string (mssql:// and the firewall on the Azure portal. The firewall requires the IP address to be added so that it allows incoming connections. Can someone please help with this as I would like to complete a proof of concept that will result in me moving all my projects to bubble … assuming this works of course.

Can someone help??


The time out means Bubble can’t talk to your database, so it has to be on the db side of things, if the string is correct. We’ve tried with some users MSSQL db and it worked fine.

Thanks for getting back to me. I can connect now! All I did was to remove the database type in sql connector. It connected on test straight away. I never changed the database querystring at all. There might be a bug connecting to an Azure instance.
Now that it connects, I proceeded to create a query. It then says it needs to be limited to 200 with a query string that looks like this "select top 5 * from ". I am not sure if this has anything to do with not having a database type as described above.

Once again your help is appreciated

I have now created another sql database instance on AWS. This time its not Azure but a simple express database. The result is the same.

If i remove the database type, it connects fine but the query is recognized because it does not have a limit section to the query.

It looks like a bug on the bubble sql connector for microsoft sql.

Please can someone come back to me as I cannot change my backend systems as all my business logic are in stored procedures and triggers.

The 200 limits is something we have to enforce for performance reasons (but you can have queries that go above, using a cursor, we just won’t download more than 200 entries at once)

Can you file a bug report if you hit an issue ( We won’t be able to help without details.

Thanks for your reply
the limit is not the problem. I am happy with a 200 limit. Microsoft SQL query statement does not use the “limit 200” statement but uses “top 200” in the select query.

I will file a bug report regardless.

Good. The statement “top 200” should work but we’ll look into it.


Step-by-step instructions:

Install the SQL connector plugin
put in the connection name eg. testdb
change the database type to Microsoft SQL
type in the connection string
test the connection. you will see it time out
remove the database type
test the connection and it will connect
create a new query connection
run the query “select top 5 * from CM_Users” - it will complain about the limit.

Hi Jeremy - I am facing the same issue that you did in connecting to an MS SQL instance. In your Step-by-step instructions above you mention to “remove the database type”, which is your crucial step to get this to work. How did you do this? In my SQL DB connector page, I have a drop-down list for the database type that seems to force me to have one option selected (MySQL, Postgre SQL, or MS SQL). Thanks for any help you can provide on this.


Hi all!
I have problem with the SQL Database Connector. I entered Connection string name and Database type ( Microsoft SQL) but Connection string field is locked and I can not edit connection string.

Is there a solution for this?

Thank you!