Forum Documentation Showcase Pricing Learn more

Converting time picker's military time into standard time

I can’t figure out how to change the time picker’s hour picker from 24 hour time to 12 hour time.
Is it possible yet @emmanuel ?

There is an option: Time Format that lets you choose between 24 and 12 hour format.

For some reason I don’t have that option.
@emmanuel what do you think?

Well that is definitely interesting. My only guess is that it could maybe, possibly, be related to a plugin. My thought would be the Calendar Plugin. Do you have that installed?

I just added the calendar plugin and created a new time picker but I still have no option to change the time format.

It’s in the style. Remove the style or modify the style and you’ll be all set.

3 Likes

Can you help me more with this? I deleted all of the time/date styles, but I don’t see anyplace where any time formatting options appear. There are a few date formatting items, but no time formatting ones, either in the Styles or the Design tabs. Also, it appears that the time zone isn’t consistent. When I schedule an appointment, it registers in the local time where it was created. The verification email shows a time 7 hours off… assuming that’s a time-zone issue, but I don’t know where to fix that.

Ideas?

So we do have an issue with timezone, that we haven’t fixed yet. Here is a workaround. The solution here is that we want to calculate the text value of the date on the user’s computer, so that we don’t need to worry about where the server is. So the trick is to use an input that is hidden that will convert the ‘date’ into a ‘text’. To do this:

  1. add a input named ‘date converter input’ (or whatever) whose type of content is text on the page and make it non visible by default (check the box at the bottom)
  2. define it’s content as ‘Date input’s value’ + some formatting if you want some
  3. use the content of that new input for the email ‘date converter input’s value’

We’ll fix this at some point, but in the meantime that should do it.

2 Likes

Thanks. The workaround worked perfectly. Still can’t get the time format to show up like on the image above. I’ve tried to re-format the time picker from every angle.

Which image? Can you share a link?

In the first reply to this thread is a full screenshot. If you look closely, the properties box for DateInput has a “Time Format” drop-down (selected in the image) that doesn’t exist in my project.

That’s because it’s part of the style. Remove the style or edit the style and you’ll be able to customize that.

@emmanuel I can’t see where in the style I’m able to change military time to standard am/pm. I’m still pretty new at this so I appreciate the help.

If you click on ‘remove style’ you’ll have access to all the options.

@emmanuel I have removed all of my date/time picker styles and changing the time format from military to standard is still not available to me.

You’re still applying a style to the element. Remove it.

Click the “Remove Style” under the Style Box 3/4 down the dialog.

Thank you for the help, Super appreciative!

-Ken

You can get here Right converter of Military Time to standard time.
thanks

you just bumped a 2 years old topic. Congrats @mkboss72