Copilot Data API adding Things to version-test from live version

Setup a API Workflow that creates things into the DB through the @copilot Data API.

I need some urgent assistance now as any version workflow triggered (test/live etc.) creates the things in the version-test version.

All other data in the workflow action is created in the Live version except for the Data API things - those get created in the test version.

So in the live version:

  1. Post JSON data to endpoint:
  2. Create new unrelated thing (created in the live version)
  3. Create things from DataAPI (created in the test-version)

@copilot I have tried reaching out via chat but it disappeared and also logged a bug via your site. Would appreciate if you could urgently assist.


1 Like

If the workflow use a POST to an API endpoint, be sure that the POST url doesn’t contain /version-test



Just fyi - I am using the Live versions and not /version-test/… All actions in a single workflow creates and updates things in the live site except for the DATA API plugin - that gets created in the version-test version.

I mean that your workflow request to data API may point to version-test endpoint and this may explain why whrn you test in live, the request to Data API is done to version-test DB. I guess this use thr API Connector. Check on this side.

Hi, This is using the Data API created by @copilot as below. It should automatically create in version-test when the version-test workflow endpoint is called and in live if the live endpoint is called:

Live endpoint: (This should create records on live version)
Test endpoint: (This should create records on test version)

@copilot - I know you mentioned that you do not offer support over the forums however I have not received any feedback via email. Any feedback/update on this issue will be much appreciated. If you can maybe assist with an interim workaround also I would appreciate!

Hello. I have the exact same problem. Did you ever hear back or figure it out? I tried creating a different token for live vs. test but that still did not work…

@lmourasse, If I recall, I eventually ended up logging this with Bubble as a bug and was resolved. Maybe reach out to support for assistance.

Best of luck.

OK. Thanks @pieter for getting back to me. Will try that.
It’s a very strange thing…

Hey @pieter and @lmourasse,

Be sure you’re on the latest version of the plugin and are setting the Version field. :slight_smile:

1 Like

@pieter This is how it looks after downloading the latest version. Putting it out there if others face the same problem one day:



Instead of writing separate workflows for test and live versions, you can use bubbles “App version” option, “version-App version”. See screenshot below.


The weird thing is that I’m seeing the same base URL for the Data API, when I go to live mode or to test mode.
This shouldn’t happen because the POST request to data API to create a new thing is creating it in test mode, so when app I run in production, it’s not able to access the data.