Cannot run API workflows on new data types or fields in new version

Update 13/12/2019:
The Bubble engineering team has updated that a fix has been deployed for the issue

Update 14/12/2019:
After a quick test, the issue still persists and has not been resolved

We are working on app that has versioning, so we have the main app live, with the standard ‘development’ version but have also created a new version where new features are being worked on.

So when the new version was created, we added a half a dozen new data types with fields in this new version along with adding fields in data types that already existed on the development version.

Now when running a few workflow actions on the new version like ‘create a thing’ or ‘make changes to a thing’ on the client side on these new data types we’ve create, it all works fine and creates new entries or modifies as you’d expect, looking in the App Data section. However if we then copy those actions to a new API workflow endpoint and then schedule the workflow to run server side, it wont create the new entries in the new version.

Looking back at the ‘development’ version, these new data types and fields are not created there and that sounds correct. But it appears that data types missing from the ‘development’ version cannot be interacted with using API workflows on another version where these data types don’t exist yet, in the ‘development’ version. So essentially the ‘development’ version data is centralised in API endpoints/workflows for data types, anything not in that version, when using a new version, cannot complete.

@eve please can you confirm if this is a bug? It would seem quite problematic if we can’t setup API workflows to run in new versions of an app that use new fields or data types (outside of the development version) compared to other versions. Perhaps there needs to be a specific merge option for data types, as we cannot sync this new version with the development version due to app breaking changes currently in the works.

p.s. I’ve tried with a simple test to create a new thing on a API endpoint, with ignoring authentication and privacy rules - and still doesn’t function as expected.



This certainly sounds like it may be something funky; can you please go ahead and file a bug report so that our team can take a closer look?

Hi @eve

Okay sure thing, I’ve submitted a detailed bug report with an example page as well to showcase the API endpoints not working with new data types (or fields) that have been created in other versions. Cheers.

Quick update to post:
This has been logged as a bug by the Bubble team and now being assessed by the engineers. I’m really surprised this has not been addressed sooner, but I guess the versioning is very limited on the plans its available too.

I will post further updates upon hearing back…

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.