Custom State not changing .. bug, any idea why?


I have a system where a user clicks a button, then after that, input boxes get filled with text. The text is dynamic and is different based on each button clicked.

However, this is the issue:

Let assume, user clicks button, the text gets successfully filled.

If the user then after edits the text that was filled, then clicks another button, the input box will NOT fill with the dynamic text assigned to that button click.

This only happens when the user edits the input box, otherwise everything works perfectly (the user can click multiple buttons and the text constantly fills with what is supposed to be there). Any idea as to why this is happening?

I do in fact want the user to have the liberty to edit text and still have the text change when button click happens.

Here are screenshots of the workflow:

Appreciate any help, thank you.

I’ve tried clearing the state before setting these states.

Basically, create an empty state for an empty value then set it to these states in the workflow, but still same error.

Think it might be some bug with setting the state itself? The state can’t change to the new value once it’s been edited by the user?

This topic was automatically closed after 70 days. New replies are no longer allowed.