Custom States are not always working- same workflow

Hey there,

Hope you are all having a nice day.

I wanted to stop by here to ask if this has happened to you recently in regards to custom states.
Earlier this week I set a custom state (yes/no) in a group of fields, then set a workflow that when Button A is clicked it sets the custom state to “yes” and lets me modify information in my DB, then another workflow for clicking same Button A and only when the custom state is “yes” then set the state to “no”. When I did this the first time it was working fine, but then today when I came back to keep working on my page it stopped working.

I have not changed anything in the workflow but I double-checked everything and I cannot find the reason why it worked two days ago and it’s not working today.

Has this happened to you? Any ideas on what is happening and how to fix it?


Hi there, @dafne.sinopoli… it will be difficult for anyone to help you without knowing more about your setup. Can you share screenshots of the custom state, any other relevant elements, and the associated workflows?


Yes, absolutely. I tried adding everything that seemed relevant in the pics, not sure if something is missing.

Edit Company

I’m not 100% sure, but I think the issue could be that you don’t have a condition on the workflow event in the second screenshot. I would try adding the following condition to that event: Group Company Inputs's Edit C Mode is "no"