Cut Off Content If the Element is not Tall Enough


I took the “Cut Off Content If the Element is not Tall Enough” option for a Text Box in a Repeating Group to indicate it would keep the cell height constant and if the text in the Text Box is longer then the box itself, cell wont grow and it would cut off and show 3 dots. Is this the intended functionality for this feature? When I check mine off, the cell shows no text at all. Dont see any other way to keep the row height consistent.



I would double check to make sure the actual height of the single line text element itself is tall enough for the font size you selected. If it’s not big enough you won’t see anything at all.

1 Like

John thanks for the suggestion but doesnt appear to be the issue. The text boxes which are set to a small font size of 1 fits fine with height just when length of text is longer than the field itself, it goes to a second line which makes the entire row two rows tall. Just in case, I made the text box larger and reduced the font further but still blanks out entire cell when rendered. Once I take the checkmark out of the “cut-off” function, everything appears again.

You should probably copy and paste some screenshots of what’s happening and what your bubble settings are for the element as I can’t really understand why you would have the problem you are saying.

John I apologize for the delay in getting back to you. I have resolved the issue. It had to do with formatting with rich text editor. Once I relied on Styles and removed all rich text tags, the cut off function worked as described. Again, thanks for your help

Hi guys,

I’m having this same problem at the moment. The blue box in the below screenshot is a “tag” (a text element with colored background) within a repeating group. The text value is too long for the box but instead of showing the 3 dots (…) the page renders without the text at all. If I increase the element height, the text does show (in it’s entirety).

Thanks for your help.


The “cut off content” option works on a word by word basis; Bubble will only cut off words at points where there are spaces in the text. I’m assuming the text you’re trying to display is either a continuous string of characters without spaces, or the first word in the string of text is too long to be displayed in it’s entirety. Check out this workaround if you’re still having this issue:


Thank you for sharing

1 Like