Dalle-3 / API connector issues

Hey all,

I’ve previously set up Dalle-3 via the API connector and it used to work, but now I keep getting 1015 error. Yes, I understand this is technically an OpenAI code saying that I don’t have funds, but that’s not correct - I do.

I’ve seen a lot of people with this issue in the past (Error 429 (1015) with Dall-E 3, but quota/rate not reached (Bubble related?) - API - OpenAI Developer Forum) but I can’t see any solution. Has anyone found a solution to this?

Thanks!

Ive been getting 1015 errors since last night. Haven’t touched it for hours, still getting 1015 errors. Previous searches for this issue indicate a likely API connector issue. Bubble support will initially respond with their boilerplate response telling us to check with Open AI.

I am also having the same issue. 1015 errors since last night. I have the same workflows set up on Xano. Everything runs fine, so not an OpenAI account thing.

My hypothesis: There were too many requests coming from Bubble users to Dall E 3, so it got flagged and automatically rate limited requests coming from the Bubble IP addresses. This is due to all of our requests coming from one central server cluster vs. separate instances.

Basically it’s OpenAI’s automatic systems protecting from DDoS attacks. Unfortunately not much we can do since we don’t own the servers that are getting rate limited.

1 Like

same problem…

seems that it is solved

same, working again for me.

looking back at the history, this does seem to happen periodically, though. so for anything critical on the image generation endpoint, i’ll probably put a fall back in place through another server.

Spoke too soon on my end. Back to intermittently getting the 1015 error. Time to build out that fallback option.

I was already looking at different txt2image api services and now I’m sold. Do you recommend anything in particular?

Seems I’m back working now as well, but I dare say this won’t be the last time this happens.

Don’t know any text to image to recommend sorry @kurt8 but I’m all ears if someone else has ideas.

Hello, I’m getting the same error here, even though I have some funds into my account. Hope we will find a solution soon cause Its block us from building

So, yes, I have been having similar issues with the errors (429, 415) and have an account (OpenAI) with plenty of funds. I have rebuilt the workflows, thinking it was on my/Bubble’s end. That was unsuccessful. Very frustrating as we were so close to a soft launch. Any solutions in the past week?

Oh, has anyone used the Midjourney plugin?

In soft launch phase as well, I havent tried MidJourney plugin but I’ll likely take a look. I’ve setup a StabilityAI call but I’m not fond of the pricing.

Bubble should just proxy our requests for us. I have seen so many complaints about openai and other rate limits lately

This is why workers are a thing.

Of course can’t agree more :slightly_smiling_face:

But this is a no-code tool, and as OpenAI is the most popular AI tool out there a solution that is built in feels like a natural choice to make

Though I agree, AI wasn’t their sole purpose/intention to begin with. So compatibility, adaptability, and reliability will likely be a long haul for AI functionality.