OpenAI Dall-E API calls error HTTP 429 error code 1015

Hi there,
Anyone else experiencing that issue ?
When my app makes a call to OpenAI to create an image from Dall-E, I consistenly get an error code 1015 / HTTP 429 which I believe is an issue that a few other users encountered on March 24 and then on April 17.
I have opened a ticket to both Bubble and OpenAI but reading from past messages on the forum, it seems that the issue sits with Bubble.
Two requests to you :

  • if you are facing the same issue as well, could you please open a ticket to help raise awareness on this issue ?
  • if you have identified a workaround, could you please share it ?

Before anyone asks, I have done all the checks related to my OpenAI account, credit, balance, etc and the application was working fine a few hours ago.


  • Retry after a brief wait : Done - I still get the same error
  • Rate limits reviewed : OK - I am way below my limits
  • Monthly quota reviewed : OK - I am way below my quota
  • Credits balance : OK - I still have a positive balance
  • Monthly budget : OK - I have not exceeded my monthly budget
  • API Call review : OK - it is set up as per the documentation. However, when I try to reinitialize
  • API Key review : OK - it is still working as chat completion calls going through the same API key are OK
  • Outages : OpenAI status page announces that all systems are operational
  • My API call is set up as per the documentation :
    -H “Content-Type: application/json”
    -H “Authorization: Bearer $OPENAI_API_KEY”
    -d ‘{
    “model”: “dall-e-3”,
    “prompt”: “un chat sur un transat”,
    “n”: 1,
    “size”: “1024x1024”

Thanks for your help fellow Bubblers,


1 Like

You already read the forum about this issue and you probably already found that there’s nothing you can do from Bubble itself.

The issue is not “Bubble”. The issue is not “OpenAI”. Basically, OpenAI apply limit to server that are doing request. This is not an issue, but a limit.

Maybe Bubble could negociate with OpenAI to remove or change this limit. Maybe you can talk to OpenAI to change how this limit work (instead of being based on server, it could just be applied to account/key).

For now, the only work around is to use another provider or your own server request. I guess some user do function like aws, azure or google. So they can continue to use API Connector but instead of doing request directly to OpenAI, they send it to the function that is calling OpenAI and return the result.

@imoranfr Are you using a plugin to perform this action?

It worked for more than a year than suddenly stops working and sends and error message that is not consistent with the actual issue… This is not a limit but an issue for me. A limit is something that is known, a parameter you can manage. Here, it is completely random and there is nothing you can do as a user.
Would you have a recommendation about a function to use as intermediary ?
Thanks for your help,

Hi Ali, no plugin. Just the standard Bubble API connector with the standard OPEN AI API call

This is a limit related to OpenAI. Not to your own OpenAI key/account but to the server from where the request is made. Since all Bubble Apps share the same server, it’s not just apps that are doing request to OpenAI but all apps. There’s more and more apps that are doing request to OpenAI and now apps are receiving more and more this error from OpenAI.

Some user choose pipedream (could also be make probably, zapier…) It could probably also be possible using a proxy service. Maybe some other user already implemented some workaround solution and can recomment you one.

Finally, a last option that I didn’t mention: dedicated Bubble server. But you will need to pay$$$$

Here’s one topic with a solution from @georgecollier

Yep, this is still up and running on a no guarantees basis.

I’m getting this 1015 issue as well, usually if I retry the call it works, but not today

We’re experiencing the same issue

Yes, same here, very frustrating… Is it affecting all users that use dalle API from bubble?

This is an OpenAI-imposed limit on requests coming from one server. Bubble apps are hosted on one (or a few) servers. That means that if lots of apps make API calls, OpenAI thinks they’re all coming from the same place, and imposes a limit. Bubble cannot do anything about this limit. It is OpenAI’s responsibility.

You have three options:

  1. Make the call from the client side. This will expose the API key, so only use it if your users provide their own key.
  2. Make the call from a server side action. Server side actions are Lambda functions so the request wouldn’t come from the main Bubble server. This was confirmed as a good option @nick.carroll on Slack. Keep in mind, if you don’t code, making a SSA would be a little confusing.
  3. Use the solution I provided, by simply changing the API call URL and adding a header that contains the OpenAI endpoint’s URL you were previously using, with no further action required. Rate limited by OpenAI DALLe - #23 by georgecollier

Didn’t know that. Good to know and thanks to share @georgecollier

So mine started working again after a quick chat with the bubble support, not sure that was the fix though, but Im getting some nice images generated as before :smiley:

Just got the http 429 error :frowning:

7/6/2024, 9:40:52 AM
Workflow error - The service OpenAI - Image Generation just returned an error (HTTP 429). Please consult their documentation to ensure your call is setup properly. Raw error: error code: 1015

Clarifying that it needs to be a plugin SSA, not a normal backend workflow in your app :slight_smile:

1 Like

Many thanks for this Jici

Many thanks for taking the time to outline these options George. Much appreciated.

1 Like

Really appreciate the info. By SSA with a plugin do you mean making our own plugin to make the call? If so, any documentation or starting points for how to best do that? Thanks!