Forum Academy Marketplace Showcase Pricing Features

Data Source error - not showing any options?

I’m having an issue when I set up a Data Source and configure correctly (it’s displaying blue), but the dropdown in the next step isn’t show any options and shows an error.
Repeating Group is using API Call as Type of content > API provider selected and variable selected.


Then when I select Click, nothing actually opens and there’s no options to select? I’ve refreshed, tried replicating elsewhere and using different values but still nothing.
Issue 2
And finally if I click away it shows an error/incomplete.
Issue 3

Not sure what I’m doing wrong and why I have no options when I select Click.

This shouldn’t happen if the API is set up and initialized correctly. It’s possible that response from the API was initialized as empty.

Can you share some screens of how the API connection is set up?

Cheers,
Ranjit | Blur Apps

The call was returning results no problem before I tried adding a variable, likely this is where I’ve made the mistake. The only change was where I added Listing Suburb.

I just realised I’m now seeing this notification when I initialise - I’m not sure what this means?

Yes, the API is returning an empty array.
There’s nothing there for it to display.

Looks like it’s set up fine.
I’d cross check whether the listingsuburb parameter being passed to the API is correct and has some data associated with it on the API server end. Maybe it isn’t able to find any matching entries?

While initializing the API you should pass a parameter value. Looks like it’s blank right now.

1 Like