Date Range Not Saving in Database

I’m having an interesting issue and I’m hoping it’s user error. I can save a date range into a state but the date range will no longer save to my database.

Also, all of my date range entries in my database show as ["",""]. I’ve tested multiple apps.

@garet.send Is the Field Type in your database field set as a date range?

@lantzgould yes it is. It’s worked for the last 3 months when I set it up. I just noticed it was not working anymore. I created a new app and I am getting the same issue with number ranges, as well. Is the date range working for you fine?

@lantzgould here is the set up:


@garet.send Yeah I’m getting the same result… I’m able to create a range but am getting the same when saving to the db.



I’d recommend having two date fields in the db then producing a range when viewing.

Edit: I’m seeing other posts mentions of the calendar range producing the same thing. Maybe a bug.

Unfortunately, that would not work. My booking system relies on date ranges.

@emmanuel the date range function is broken :frowning:

Change the topic to Bug. Bubble team usually watches that one. :slight_smile:

People, people, people… file a freaking bug report:

This is a pretty serious problem. I’m reporting my own findings, but if this affects you, file a report.


Same issue with a range slider auto-bound to a numeric range field. Bug report filed.

1 Like

Yeah date range data isn’t even being displayed on previously created items with date ranges

1 Like

@emmanuel, @josh Please can you look into this. Date range has stopped working and its broken a lot of my client’s app.
I’m guessing there has already been some bug reports filed on this.

1 Like

Filed as Bubble bug report #7629 (with prejudice). You can clearly see the problem here:

Use the CG Pro element to pick a range. Now click “store that range in the db”. Note how the newly constructed range is [null, null] (as shown in the text element and in the RG).

1 Like

Worth noting: It’s RETRIEVAL of date ranges that is verifiably broken. The repeating group on the page I link to contains (or, perhaps, DID contain) valid date ranges. However, a query (“Do a search for…”) as well as the App Data tab show them as [null, null]. App Data screencap:

The ranges created in April and on Sept 19 are completely valid, but their values are not returning properly.


Correct. See my posts below.

@keith thanks for the update. I filed a bug report about 7 hours ago and emailed Neema, as well. No response yet. Very frustrating.

1 Like

Well, the team is based in NY, so Eastern Time.

I’m sure it’ll get rectified fairly quickly, but it’s a bit baffling how this could happen. That it did happen indicates that Bubble has no automated tests configured around “higher order” Bubble data types. It’s not a minor issue – they broke the language, not just some random user-created API to the platform. It shouldn’t be possible to push an update that breaks the language.

(But in a way this is no surprise: Date ranges are red-headed stepchldren. You’ll note that there’s no way for [for example] the API Connector to return a higher-order “data type” like date ranges. It only supports pure JavaScript data types and core JavaScript API objects [e.g., dates, which are not a data type in JS, but might as well be]. Date Range objects are, at their core, a 2-element array of JavaScript date objects [date_1, date_2].)


Still 12 hours later and there is no word or fix for what can be such a critical component to peoples apps :expressionless:



1 Like

@luke2 It’s very unfortunate. It’s a little frightening knowing this can happen.

Yeah I’ll be honest, its a little worrying something like this can slip through the cracks. I just hope this gets addressed promptly and future precautions are setup to avoid this kind of disruptions.

Hi all,

Thanks for flagging this; we are looking into it now! Agreed this is a very urgent one for us to investigate further.