Difficulties setting up an API End point

Hey, I am really new to this all API thing and I am probably doing tons of mistake at my beginning.
My goal was to generate an RSS feed, as Jason parameters, clean some columns etc.

I’ve been using Parabola.io and has successfully achieved the time of data I was looking for.

The only thing that is missing is Exporting the API.

I’ve enabled the API settings, purchased a personal plan, went to API Workflows and setup a new endpoint:

After going to Detect data, I’ve copied the link:

And posted it in the parabola as the API Endpoint:

When I am trying to run it, I am getting a 404 Not found error. I contacted parabola support and they said that it is usually happens when the endpoint doesn’t exist, so the mistake is from my side (bubble).

My goal is to simply be able to aggregate different sources of news channel, and it seems that I’ve succeed doing what I had to with parabola, but I can’t bring this data back to Bubble.

Can anyone please advise?

Try checking the boxes “can be run without auth”, “ignore privacy rules” and “include headers”.

And then try variations of that, with and without checking each of them. Just to see if it passes through.

Hey @vini_brito, thanks for your respond.

I’ve tried what you’ve suggested, but still getting the same error.

Did you left the popup with the link open when you try to call the endpoint?

1 Like

Yes, I am also getting a response from Bubble showing that call with the details, but Parabola still shows the 404 error.

So bubble show you all the fields?

I’m wondering why you are using Parabola instead of API Connector From Bubble?

I have no clue how can I make it through API Connector (the entire process), so Parabola was kinda good and easy solution.

Ok.So did you get the field to appear in bubble but a 404 error in parabola?

yup, but data is still empty

Ok. Not sure if this will work, but you have the fields. Maybe the response from Bubble is not the one expected by PArabola.
Now, add a Return data api in your workflow. Run the Parabola flow but remove the /initialize

How do I do that?
I am sorry for the silly question, it is one of my first times using API.

Can’t find it in the API Workflows.

look in: Data(things)

Still the same, keeping getting an error from Parabola (404), and Bubble shows one sign:

But when I click on Save, the data is still empty, also in the ‘raw data’ it is giving only one call.

Not sure if you are doing thing correctly.
Normally you need to do that:
You will click on Detect request data. COpy the link, let the popup open.
Go in Parabola, add the link to the API Export, run it. This will give you this screen in Bubble where you have all field. If you don’t need to modify type, just save.
Create your flow, for example
Create a new thing and use “Request data” to choose the field you need.
Go back in Parabola, just remove /initialize and run.

Still can’t solve it, any other that I can try?

Maybe you can record a video of each step and post and we can help you

Ok, hope it will make things more clear.

So I am starting from a blank page in Parabola:

Building the work flow I want, Import RSS feed, flat the json code and filter it

Converting the rss link to to json using https://rss2json.com and adding the link to Import API endpoint:

Then going to JSON Flattener to view the data in columns:

Once I have all the columns, I remove the one I don’t need using Column Filter

So now I have the data that I need, and all I am suppose to do is to export the API back to Bubble.

Meanwhile in Bubble:
API Settings:

API Workflows:

Used the bearer token as well, placed it on the right place. Clicked on Detect Data:
Then trying to process it from Parabola to Bubble:

So far, everything seems to be ok, but now the issues starts:

I am clicking on Run Now (Detect Data is open).

Results from Parabola:

Results from Bubble:

And that is my issue…

Hope this explanations will get an answer :slight_smile:

Remove now /initialize from Parabola and you are set.



Hi, i am having a similar issue, i can`t “initialize” my endpoint using parabola, just getting a 404 error. I think that everythink is ok with my configurations.