Display a list in a Repeating Group

Hi everyone,

Looking to display a list in a RG.

I have a data set per below with a list of contacts

I have then set up a parent RG with the settings shown

I have then put a child RG within the parent RG with the settings shown

I have then put a text element to display the list with these settings

The result shows the child RG but no text is visible…!!!

I’m wondering if it has to do with the way I have set up the database. I have created a data set called ‘counterparty contacts’ and used this data set to populate the contact list in the original database ‘counterpartys’

Any help appreciated

Hi Simon,

Can you double check that there are no privacy rules on the “counterparty contacts” datatype that would prevent Bubble from displaying them?


1 Like

Hi Rob,
Here are the current settings - see anything that is an issue here?

Well it’s possible that privacy rule precludes Bubble from accessing the data… It shouldn’t since I assume the current user is the creator of the Things… But try disabling that rule anyway so we can figure out if that is or isn’t the issue.

Hey Rob,
I checked all the ‘everyone else’ boxes and this has worked now. Good tip thanks.

So Im having a similar issue that this solved… mostly, but I still haven’t gotten over the hump quite yet if someone can assist me in wrapping this up Id really appreciate it.

So, I have my data set “Message Thread” and “Messages”.
Message Thread contains Messages as a list.

I have a RG that contains the Users in the conversation as “Thread Title” it also contains the time stamp of the last message sent as well as the text of the last message.

Changing the privacy setting in the message thread made the thread show up in the recipients RG on their profile so that was a big leap in the right direction. This also allowed the Time stamp and the thread title to show, but the recipient still doesn’t see the actual message text. The cursor acknowledges that there should be message text in the field but it doesn’t display.

Ive so far changed the permissions to include the creator and any user that is included in the thread.

What I don’t yet understand is why the Thread Name and the time stamp will display for both Users, but the actual message only displays for the creator.


This topic was automatically closed after 70 days. New replies are no longer allowed.