Repeating group none responsive

Hi Bubble community

Hope everyone is well

My repeating group is staying blank and I have tried everything from database to privacy rules. This seems to be a common issue but cant seem to get any data on my repeating group, even with static data like text everything is blank. Anyone know what the solution would be?


Hi there,

What is your repeating group’s data source, and then what parts of that data are you showing in each cell? I see you have a Text element, what text is that setup to display from your data?

Are you setting data source to the repeating group?
If you leave data source field empty, repeating group will not display anything including static values.

Financial advice data I want to display but at the moment I’m trying to display anything

Yes I have but still the same issue

Could you send over a screenshot for what these elements are setup to display?

image

I only added those elements for preview purposes to see if it reflects. I deleted the original repeating group thinking there was maybe a bug so I will need to rebuild the RG to how I originally had it.

Just wanted to test some static data to at least see something but originally data would be from financial advice.

I only mention it because those elements will also need to point to whatever the cell in your repeating group is supposed to display.

For example, if you’re repeating group is a list of users, and you put in a Text element, that element won’t show anything unless you set that Text element to display ‘Current Cell’s Users’s Name’ or something like that.

I re-read your initial post and think I understand more of what you’re saying. If you don’t have a DataSource set, does the Repeating Group still show up as blank? I’m curious if the issue is that there’s no content, so even if you have static values set, they won’t show if those cells data are otherwise blank.

I changed all data content to USER and have 2 text fields, one in red is a static field and one below is display the users name and still the RG is empty.




What happens when you give it a Data Source (Search for Users)
image

And have you checked privacy rules to make sure Users can be found in searches?

Thank you for your assistance, that seemed to work. :sweat_smile: dont know how missed that and I was looking for a much bigger problem.


1 Like