Display a List of image


I am a new bubbler :slight_smile:
I created a thing with different fields among them a “list of image” and i see that i successfully populate this field when i check the app data but i am struggling to display this list of image in a repeating group.

i have checked the different topics but i couldn’t find any solution to my problem

Thanks for your help


This setup can be a little challenging but what you do here is set the repeating group type of content to image and then the data source to the data your are using and select the image fields.


Hope this helps you. Let me know if you have more questions
Lester from www.skylineproductions.com

Hello Lester,

Thanks a lot for your help but unfortunately it didn’t work this way but i found a solution: i converted the “list of image” into a “list of files” and i put the following for the repeating group:
Type of content: file
Data source: file list URL

btw what does URL stand for? i mean why putting URL shows the picture instead of the file’s name

it works perfectly fine :slight_smile:

Glad you found a solution.

The url just returns the url of the image, so if you take that url and open it in a browser you get that image and the reason it shows the image is because the image element will show the image from that url and not the url.

Hope this make sense.

Thanks again

I really don’t understand …this solution was working absolutely fine and today it is just not working! and i haven’t made any change

Are there bugs like this with bubble? is it common?

If you share a link to the editor I can take a look at and see if I can figure something out. If you prefer you can DM me it.

Thanks a lot

please tell me if you can have access with this link?

When i post 1 image it is successfully displayed and when it is more than one…it doesn’t work

I can’t access the editor right now. You need to go to settings >>general >> and set the privacy rights to public

i ve just sent you a message with a private access
Could you please confirm that you ve received it?

This topic was automatically closed after 70 days. New replies are no longer allowed.