Does Bubble Count Zero's Properly?

I have some custom workflow events which I’ve checked repeatedly for errors.

What I’m seeing is that Bubble is not counting the number/integer of “0” in the database…

I need help with a workaround unless I’ve made an obvious error.

A thing in my data base has individual scores (0,1,2, etc…)
My application has custom workflow events to check those scores and count them and make changes to an aggregate score when triggered.

So on trigger,
Check individual scores
Count individual scores = 0
Count individual scores = 1
Make changes to aggregate score (Scored 0 = count of individual scores = 0, Scored 1 = count of individual scores = 1), etc…

For all possible scores EXCEPT the score of 0, this works.

For Scores of 0, in the aggregate score thing, the Score Field which should hold the count is always blank.

Any thoughts out there on this?

Just do a count of scores less than 1 or count of scores where score is empty.

Thanks tried both, neither worked, problem must be somewhere else…

I re-built every related workflow item for counting scores of 0s and that resolved the issue.