Doing something wrong with data searches

It seems like I’m making some sort of mistake. I have two Data Types. User and Schedule. Basically a user creates an availability schedule. I created a data field “Schedule” with type Schedule under User.

I can’t seem to make it work when I try to show the schedule data with something like “Current User’s Schedule”. I can only make it work when like this:

but what I want is for this to work:


No need to do any searches here (assuming, as you say, you have a Schedule field on the User datatype that points to the Schedule)…

All you need to do is use Current User's Schedule's bookingLengthMON

If you didn’t have a Schedule field on the User, then you could do a search for Schedule’s created by the Current User (NOT the Current Page User)

Unless that is, you actually meant that you want to show the Schedule of the Current Page User, and not the Current User (which is what you said in your question)?.. (in which case what you had in your first screenshot is correct, and if it’s not working then there must either be a problem with the data, or some privacy rules blocking access to certain data)

Thank you. I did mean Current Page User (each user has a personal profile page, to see who created the profile page that’s how I refer to it)

It must be a privacy rule

So I temporarily turned off the privacy rules I had in the User data type, and it still doesn’t work. What am I doing wrong? This is how things are set up -


How the User data field looks:

I’ve tried Created By, unique ID - neither work

I feel like I must be doing something wrong, I can’t figure this out. During user sign up, a Schedule is created for each user successfully. I just don’t know why I can pull it up with a search and not with direct linking

Can anyone spot my error?

One last bump

This topic was automatically closed after 70 days. New replies are no longer allowed.