Error (Hard Browser Prompt): Oops, we just released a new version of this page ... What is this?

Has anyone ever seen this error before? It is occurring midway through a workflow that I haven’t changed, and even though I am not changing anything in my app while it’s running.

I don’t see anywhere within my application (e.g., Settings>Languages) where this specific message is triggered. It’s not the same one that you normally see when you actually push a new version of your app; it’s something different.

Any ideas what the cause of this could be? Seems to be very consistently happening during this one workflow run (which again I did not recently change, and I am not touching my app itself while it’s running).

Does this banner show up in your editor? Or in your preview of your site?

in Preview on /version-test of my site.

My first question is just making sure it’s something from Bubble and not from one of the APIs I’m calling. I feel like it’s from Bubble as it refers to “this page”. But I’ve been using Bubble form over 2 years and I’ve never seen this error, and it makes no sense in the context of what I’m working on today.

I have no idea then. I just started using Bubble, and I thought that it was a result of you clicking on the “Preview” tab and the banner simply indicating that you have updated your site and what it’s displaying is no longer the most up-to-date version of it, thereby asking you to refresh it so that it does show the most up-to-date version.

Does it possibly have anything to do with the AWS ses-us-west-2 degradation this afternoon (I am in San Francisco)?

I am really struggling here. I’m now picking apart my app in dev and cannot fix it. I’ve reverted to versions that I am 100% sure did not have this issue. But I can’t get around it.

Anyone? @Bubble team?

Have you submitted a bug report at https://bubble.io/bug_report?

I would, but I don’t know if it’s a bug or just something I did wrong. I’m just trying to figure out what “it” is. The error is nonsensical.

I have no idea what would be causing it, but I just experience the same. All I did was re-deploy without making any changes, and it stopped giving me the “oops” message. I read that you’ve reverted to previous versions, so not sure if this fix would work for you… hard to say since the cause is unknown, but sharing just in case!

1 Like

That is helpful to know that it has happened to someone else. Thank you.

I haven’t tried redeploying to production, because the error is happening in dev, too. Was your error happening in development as well as production?

Yes, it was in both.

I copied my entire app and tried deploying that to prod, but still getting this error in both dev and prod.

This is really annoying me now. I’ve already lost most of a day of work, and I’m still staring at something that’s broken in both dev and prod with no way of moving forward.

Sorry to resort to this, but @josh any advice here? I just want to know if this is something I can solve myself or if it’s a core @bubble issue. Thank you.

Go ahead and file a bug report.

Quick answer is yes, that’s a Bubble error; normally, it means you didn’t refresh the page after being prompted to, but it’s possible that you are getting it erroneously. Quick fix is to make a small change to your app and redeploy: if that doesn’t solve it, open a bug report and someone on the team will take a look.

I looked at this a little more closely… we show this error in two different circumstances:

  1. If you change the app (in test mode, any change in the editor; in live mode, doing a deployment), but don’t refresh the web browser, and then try to run a workflow. This might happen if for some reason your browser doesn’t get the notification that there’s a new version of the app, or if you ignore the notification and try to run a workflow anyway

  2. If a workflow fails mid-execution, and it looks like you changed the app mid-workflow.

I just modified the second case so that it’ll have a (2) next to the error rather than a (1) to make it easier to tell the two cases apart.

I did a quick check to see if there was a systematic issue with us displaying that error inappropriately, or if there looked like there was something wrong with your app in particular, and I didn’t notice anything, but if you keep seeing the issue, please see if you can generate reproduction steps and submit a bug report so that we can investigate in more depth.

1 Like

Thanks, Josh. It seems to still be error #1. I’ll file a bug report ASAP. It’s under my work account (@ed11 in forums but I don’t use it here), btw, which is why you couldn’t see it in the app associated with this forum account.

All of a sudden i seem to be getting these…ive not changed or adjusted anything in my app. I’ll investigate and see if i can find whats causing the issue in my app and report back

@edd OK so I am only seeing this when I’m running a scheduled API workflow with and external api involved…is it the same for you or are these happening in other scenarios?

In my case, it happens in a workflow when I use the action Change the email for another user.

I have a popup for creating new users and editing existing users. With a custom state, I control which actions should be run in a workflow in each case:

The action which raises this error is Change the email for another user and it is being run for existing users. The error happens if I create a new user with this popup, then edit existing user and when this action is executed during this “save” workflow, the error shows.

1 Like

when things aren’t working the first place you look at is yourself… Well I’ve taken a good hard long look and due to the fact I hadn’t changed anything yet this is happening… Leads me to the fact that something else is affecting it.
I will wait until this afternoon until Bubble come online to see if there’s any general update if not I’ll submit a bug report

For anyone else’s benefit I only ever seen the error with (1) and not (2)

1 Like

Experiencing the same issue. error (1). Happening on basically all of my workflows. Refreshing the page and rerunning the workflow always works but this is still not good. Hope this gets resolved soon! Very unfortunate timing for me…

Thanks for the other responses. The errors in my app are definitely related to running workflows. At first I thought it was only external API workflows. But then I started seeing it when merely running a login or logout flow. There are custom states involved in all cases. Also my login flow attempts to use custom states to change a Thing’s user (as user moves from logged out to logged in and I want to keep their data associated with them). I’m not using any scheduled workflows.

Sounds like Bubble has an issue going on. Haven’t heard back from my bug report yet. Agree the timing is unfortunate, as I was hoping to demo to an investor today.

1 Like