Forum Academy Marketplace Showcase Pricing Features

Error integrating OpenAI Plugin

Hello All,
First project learning bubble.
I am trying to install the OpenAI plugin and copy/pasted the cUrl code from the OpenAI Making References tab on the API Reference page but the copied code does not work. I get an error saying: “couldn’t parse cUrl. Check that you only use supported fields”. Not sure what to do here.

Here is the code I copied from the OpenAI page:
-H “Content-Type: application/json”
-H “Authorization: Bearer $OPENAI_API_KEY”
-d ‘{
“model”: “gpt-3.5-turbo”,
“messages”: [{“role”: “user”, “content”: “Say this is a test!”}],
“temperature”: 0.7

Any help would be greatly appreciated.


1 Like

Just add it manually to the API connector.


Content-Type - application/json
Authorization - Bearer sk-xxxxxxx


“model”: “gpt-3.5-turbo”,
“messages”: [{“role”: “user”, “content”: “Say this is a test!”}],
“temperature”: 0.7


Bubble cURL import is broken. Not sure what they did.


1 Like

Works for me, it’s just inconsistent.

I’ve noticed it tends to require the ’ ’ at the start and end of the call to import successfully.

1 Like

No, it has been changed.

I added a load of APIs (the one above, in fact) a week ago, and they imported OK.

Although one of the imports decided a GET was a POST so someone has been meddling.

The cURL is valid. So Bubble has broken something. Again. Again. Again…etc


I’m getting the same issue. Was working fine until recently.


Getting the same error , just flagging here so it can be fixed

1 Like

I’m also getting the same error - flagging here so it can be fixed

1 Like

I raised a bug a few days ago.

1 Like

Thanks to all for these reports. Feel my sanity beginning to return after attempting to puzzle this out for the last hour.