Error Uploading Data to DB Table - Help Me Understand Please

I’m getting the error below when trying to upload a CSV file to bubble and I’ve no idea why. I have checked the file for duplicates and it is fine (assuming bubble is considering all the fields not just the first few).

Here is the upload where I map the fields

I’m using a set of industry-standard ERDs called VCdb. This is important because there are over 270k unique vehicles and mapping accurately parts is a nightmare, hence the reason the industry developed this standard. So let’s assume I’m going to stick with it.

Here are the structures of each of those tables and where you see ‘.id’ that means bubble’s unique id:

Year Table =, year
Make Table =, make.naem
Model Table =,
SubModel Table =,
Region Table =,

BaseModel Table =,,,

and the one I’m attempting to import into:

Vehicle Table =,,,,

So the first three fields in my import file point to the relevant fields in the BaseVehicle table. And, therein lies the problem I think. I’m not certain but I think it might be because those first three fields are not using so there will be duplicates if considered that way. But if you consider all five fields then there is no duplication.

I’m really stuck and I’ve lost count of how many things I’ve attempted to solve it. Anyone got any ideas, please?

I solved this once I worked out how bubble DB tables work with fields being Data Type - it’s amazingly powerful. I simply, or not so simply, had to restructure my data and all worked fine.