Forum Academy Marketplace Showcase Pricing Features

Error uploading native iOS app - PhoneGap Issue

Hi all,

When uploading the zip file using the application loader for a native iOS app I get this error:

ERROR ITMS-90096: "Your binary is not optimized for iPhone 5 - New iPhone apps and app updates submitted must support the 4-inch display on iPhone 5 and must include a launch image referenced in the Info.plist under UILaunchImages with a UILaunchImageSize value set to {320, 568}. Launch images must be PNG files and located at the top-level of your bundle, or provided within each .lproj folder if you localize your launch images. Learn more about iPhone 5 support and app launch images by reviewing the ‘iOS Human Interface Guidelines’ at https://developer.apple.com/ios/human-interface-guidelines/graphics/launch-screen."

I have followed the instructions correctly and used the sizes required.

I can’t see this issue with anyone else on the forum so I think it’s just something I am doing

Any ideas?

Hey, see my post a while ago and try any of those suggestions.

Good luck, and please keep us posted on how it goes.

Thanks so much for the reply!

The issue I am having is directly related to iPhone screen sizes that are in the ZIP file that gets uploaded, I am using Phonegap for the build.

This topic was automatically closed after 70 days. New replies are no longer allowed.