Issues uploading app on AppStore by using Application Loader


i’ve followed the tutorial of @natedogg (CodeLess) and I’m just one step away from being able to publish my app. Once I try to upload my .ipa file (got from PhoneGap website) I get these two errors which I really don’t get how to solve:

  • Invalid Path Image ‘CFBundleIcons’
  • Missing App Store Icon 1024x1024px

I’ve already uploaded a 1024x1024px App Store Icon on ItunesConnect but seems it’s ignoring it.

Hey Lorenzo, just sent you a DM! If you can email me over those files that would be great. Most likely, it’s something small with how your image assets folder is structured.

Amazing, let’s speak privately and if there is a common solution useful for everybody we’ll post it here later on.


anyone else have had this kind of troubles publishing an app on AppStore?

Since unfortunately I’m not receiving any further help from @natedogg, I write here again asking for HELP.

I’ve checked ALL blog posts online, many of them speaks about fixing this issue through Xcode but following the PAID tutorial of @natedogg on there isn’t any reference to Xcode. He explains how to use Adobe PhoneGap Builder + Application Loader, so all the solution to my issue out there are not valid and digging a lot in every single blog I’ve found a solution yet.

I sincerely hope somebody will be able to help me because I’m only 1 step away from publishing my Bubble app.


In xcode, go to your main project file (the blue icon)

In the middle pane make sure you are on a tab called General.

Look for this section


Click the arrow and make sure you have all your app icons correctly named and sized.

Actually, I’ve solved the issue by using a new fresh approach. Forgetting the CodeLess tutorial and starting from scratch. It worked and almost for FREE.

I still think CodeLess tutorial of @natedogg is a good tutorial but right now it’s obsolete. If he updates its content so it will be competitive and useful again.

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.