Forum Academy Marketplace Showcase Pricing Features

Every element edit subtracts 1 pixel height

I’ve experienced an immensely frustrating bug for days now, that makes it nearly impossible to work in the editor.

A lot of the times (but not always) when I edit an element size, or it’s position by Centering, it subtracts one pixel of its height. So if I change the width of an element with the mouse pointer, it will make the change, and subtract 1 pixel height. If I center the element, it will also subtract 1 pixel height. Even just moving the element does it.

It comes and goes, often without me noticing for a while, ruining the height of several elements before I catch it. I’ve tried restarting Chrome, clearing cookies, etc. Is this a browser bug, or anyone else experiencing it?

Actually it also subtracts 1 pixel of width when I adjust the height now. Weird stuff, and makes it very hard to do anything.

I tried to switch to Safari, but can’t use it as no icons show up there in the editor. It’s not my day in Bubble…

I’ve noticed a pixel loss (or addition, I can’t rightly remember) too. I think it only happens to my groups, but again, I haven’t made a note of it - only noticed it.

You’re not crazy - it’s a thing.

I chalk it up to the quirkiness of the editor. I can’t think of a time the functionality of my application required pixel perfect groups.

Whenever I notice it, after being annoyed for a few seconds (or minutes), I blame obsessive-compulsion and remember wabi-sabi. Or I manually input the dimensions of the group, refresh the editor, change from snapping to grid or elements to no snapping, or wait for it to clear up.

I just switched the browser to Chrome and everything works perfect :slight_smile:
I was using Safari before

Did you experience the bug before you switched?

yes. Exactly as you described

Haha, typical, I’m using Chrome, and was thinking of switching to Safari :slight_smile:

That does lead me to think it’s a system bug, rather than browser bug though? Some combination of settings that messes with the coordinates.

I noticed it also changes elements inside groups. So if I change the width of a group, the elements inside sometimes have their height changed.

Today it has gotten worse actually, and now affects both height and width. Elements all over the place are changing size.

I’ve reported the bug through the reporting tool today, as it’s severely affecting the work at this point.

I’ll let you know if I get any updates.

Sorry guys, I was unaware that I had zoomed a level on the page by mistake. Bubble is know to have some issues with zoom levels, so this is to be expected. After I changed it, the problem has disappeared.

For future search results:

Solution: Check to see if your browser’s zoom level is neutral.

There should be a message if you use a zoom, if not let us know.

I can’t see any message, tried zooming several levels up and down.

(I remember having seen it some time ago though, so it has been there at some point.

We don’t show it too much, as it gets in the way, but it’s very bad idea to ignore it.

1 Like

Yeah, I’ll keep that in mind from now on to ensure it’s neutral if I experience any visual glitches.

Thanks again for checking it out.

This topic was automatically closed after 14 days. New replies are no longer allowed.