External API Image Not Showing


I need help getting the image from my API to render in the repeating group of my app. I have the API working so that the name and other data is being pulled, so I know I’m connected, but the image will not render.


“Main Building” should have an image like this next to it, because it exists in the image property being called by the API:

This is what comes through in the preview:

Here’s the API setting that appears to work short of rendering the image:

along with the returned values and raw data:

I would be grateful for any pointer someone may provide. This is my first time using Bubble and this community, so it’s likely I’m completely in left field on this one.

At first glance, the API appears to be returning a list of images, so try using :first after the image in your expression. There’s just one image in the list, but it’s still a list.

@shot, Thanks for the quick response! If you mean “:first item”, I gave that a go but no luck:

Yeah, that’s what I meant. If you simply copy and past that link into a browser address field, does the image appear?


I tried entering:


into FireFox and it didn’t find anything. The image is not public, though, as the API is working with a client ID and secret to access LimbleCMMS data, so I wouldn’t expect to be able to see the image using the link alone.

I’ve reached out to LimbleCMMS for support, and they shared the following info:

The URL allows you to access it. How you do it all depends on the programming language you use and is only a quick google away :slight_smile: For example here is one for PHP: https://www.geeksforgeeks.org/saving-an-image-from-url-in-php/

Not sure how “saving an image from url in PHP” works with the Bubble.io API Connector, so I started here to see what I might find.

Just noticed the TLD for that domain is OOM. I don’t think that’s a valid top level domain. I wonder if it should be COM?

1 Like

Brilliant!! I just fixed that and tried again and got this result:

Yes! So, that means that LimbleCMMS screwed up systematically on all of their links…LOL. :sweat_smile: :rofl: I bet that’s easily remedied and hopefully I will get this working!

1 Like

:laughing: :+1:

Yeah, some keyboard pokin’ geek done made a typo. I’ve never done that. :wink:

Thank you so much!