Forum Academy Marketplace Showcase Pricing Features

Facebook login doesnt work half the time

When users login using facebook from mobile web browser (e.g. safari), the page is stuck at logging (blue bar progresses as slow as snail and never logs in using facebook). This happens ~30-50% of time especially with first time users. Is this is a bug or do I need to do something beyond login using facebook in the workflow after adding plugin.

If you think it’s a bug email us at [email protected] with a way to reproduce.

Thanks

I have noticed that the Facebook API does not respond quite often. It never responds when the user is accessing the internet through a VPN such as PIA with “known” IP addresses.

Well written sites and apps check this and respond with an appropriate message.

Poorly written sites and apps tend to hang waiting for a response that will never come.

The Chrome console is a good way to see this problem in action.

Peter

If you can find a situation where this happens reliably, please report the issue with a detailed way to reproduce at [email protected]

Thanks

I don’t know whether you have solved the issue here. I am running into the same problem. When I log into my app on the desktop it uses OAuth for Facebook flawlessly but when I access the app through safari on my iphone 5 it only shows a blue progress bar but no redirecting. I also tried to login on another bubbler’s app cpa.bubbleapps.io and it didn’t work either - Don’t know if I need to make any additional adjustments beyond using the “signup/login with facebook” event for the app to work on a mobile device? It doesn’t seem to affect anybody else… so I’m confused as to whether this is a bug or just me missing something.

I’m having the same problem.

Here’s a link: anon3.bubbleapps.io. I think there is a bug with mobile login because it shows the blue progress bar and then can’t continue on to the site.

-Bill

and logging in on desktop using the same plugin has been smooth

@emmanuel i’m having the same problem as well. signup/login using fb does not work on an iphone 6 mobile safari. gets hung up loading

2 Likes

it’s mobile (iphone) safari that’s messing things up. chrome works. :frowning:

were you ever able to look into this issue?

This is a thread from October 2015. If there is a bug and you need us to look into this please file a bug report with a very clear and detailed way to reproduce. That’s always the way to go.