Failed to load resource (javascript)

These 3 javascript resources are failing to load and it’s causing an issue.

https://canvg.github.io/canvg/rgbcolor.js
https://canvg.github.io/canvg/StackBlur.js
https://canvg.github.io/canvg/canvg.js

Can anyone tell me if this is likely a Bubble bug or more likely a plugin? I’m not sure how to tell.

Hey @philnauta.

You can troubleshoot by loading without the plugins…hover over the preview button.

44%20AM

That would be some plug-in (or custom code your app is otherwise using).

(Aside, Github.io isn’t designed to be a CDN, so whatever plug-in this is isn’t set up in a super-robust way.)

You could also check out the demo pages of plugins to see if you can find the culprit. Those links indicate a plugin dealing with images, so I’d start there.

Thanks all, turns out it is a plugin and the developer (@zeroqode) says it’s not their issue - it’s Bubble’s issue because Bubble is the one using Cloudfront. I’ll file a bug report and post back here if I get a solution.

That’s concerning its using Github for this! What’s the plugin?

Hello,

The links

https://canvg.github.io/canvg/rgbcolor.js
https://canvg.github.io/canvg/StackBlur.js
https://canvg.github.io/canvg/canvg.js

do not work, even if you click on them here. So there is an issue with your settings, or the plugins, outside of Bubble.

Hi everyone, thanks for the help. It’s the ‘Bubble Page To PDF Converter’ from Zeroqode. The issue was a conflict with my Zoho Desk script. Zoho Desk made a change to the script so now it works in Chrome and Firefox, but not Safari and Internet Explorer. Zeroqode says it’s not their problem and Zoho says it’s not there’s, so I’m looking for another solution.

Anyway, thanks for the tips :slight_smile:

Update: They eventually fixed it. Thanks @levon!

2 Likes

This topic was automatically closed after 14 days. New replies are no longer allowed.