FINALLY! Bubble + external fullscreen video

“It can’t be done!” they said.
“It’s a Bubble limitation” they said.
“Earth is flat” they said…

Well, guess what! I got it working! FULL-FREAKING-SCREEN VIDEO on a responsive page using external video.

I’m using JWPlayer to accomplish this. I tested every plugin to no avail… and finally, it worked with these guys. A simple HTML frame and drop in their iFrame embed code and BAM!

@emmanuel Do I get a sticker?


Great! info: JW Player

1 Like

We need a plugin for this bad boi! Analytics, video customization, video libraries… oh my.


Nice! Does their javascript player on page version work as well for this or only iframe embed?

I’ve done this as well, but when I resize the screen, the video goes to a white space. It is in a busy page as have other things happening. Have tried on a simple page as well and have the same problem.

Are you willing to share the code of how you did this?

Running the latest version of Bubble.

How did you do it @alejandrowunderlich?

Hey guys, sorry for the laaaate reply! It’s very easy to get this done, and robust, too! Our library of videos on JW is 320 videos and all streaming great.


  • Create an account in JWPlayer ($10 for starters. We’re now on a $110/mo plan for the storage and streaming)
  • Get the player code from there
  • Upload a video or two in JWP, then copy the iFrame embed code
  • Drop the iFrame code into an HTML element

BAM! Does this make sense?

I also believe @ZeroqodeSupport fixed their video player plugin that now works fullscreen on responsive pages. Is this true guys? @levon

1 Like

Hi, @alejandrowunderlich!

Yes, that is correct. We have fixed the video player plugin and the fullscreen works well.

Zeroqode Team

Hi, I’m trying to implement JW Player, and when the player appears, it makes a weird behavior on the left side… I tried changing some things on the player, but none worked…

What configs have you used to make the call?

This config was able to get the video, but I can’t use like this…

Could anyone help me?

The print doesn’t show, but I’m getting type “text” in the call