Find Element User Is Not [XYZ] userType

Hey guys,

I have 2 user types & [Z]

If the user is a userType I want to hide a button from them. How can I make this happen?

Screen Shot 2020-10-11 at 11.36.13 AM

Hey @samhouston1107,

I’ve read your question about 5 times now and forgive me for being dumb but I can’t quite figure out what it you’re trying to achieve! Do you mean that you want to hide that “profile” button when a specific user is logged in or something? Or is it that you want to hide it if a user actually exists somewhere in your User table? or if they have a specific name against them? If you could elaborate just a little more then I’m sure you’ll get a few more replies :slight_smile:

It’s worth noting, that the “contains” operator will only look at complete words here, so it will evaluate as true if something like “Bob Farmer Jones” exists but it won’t work with “BobFarmerJones” (I think).

Yeah, I want to hide the Profile Button from a user type. I want it to be hidden.

Sorry man, I was typing way too fast haha.

ok so in your “do a search for user’s” add a condition in there for your user type and then put a count > 0 on the end (or greater than or equal to 1), so you end up with something like this…

I don’t see contains? I’m trying to hide a button. Your example has a repeating group.

Can you share a link to your editor? I’ll take a look

Let me know if this works/

Go into the settings and under the General tab, you’ll notice the top option there called Application Rights - set that to everyone can view. You can always change it back after we’re done.

Going to make a couple of changes! bare with me for a sec.
Do you want this to work when the user is logged in right? So if the user is logged in and their User Type is set to Farmer, then that button will not be visble?

Yes, when the user is logged in.

When the user is a farm the button should be visible.

I’ve changed the condition on the profile button to read this
So when the user is logged in and their User Type is set to Farmer, then they wont see the button

image

Does that work how you want it to?

Did you type Farmer?

I did yes, because I specified User Type’s Name in the condition, Name field having a field type of ‘text’

You are the man. Thanks so much.

Glad it works, you’re welcome

This topic was automatically closed after 70 days. New replies are no longer allowed.