Find & Replace - multiple instances in one expression

It would be super handy to be able to build multiple Find & Replace instances all in one expression (similar to the ‘Add field’ in making changes to database) - example:

2020-04-10 12_14_59-Window

This would save a long separated expression such as:
2020-04-10 12_14_24-Window




1 Like

This would be a huge timesaver! :slight_smile:

1 Like

vote +1

I tried this and it worked:

  1. Check “regex expression”
  2. enter expression (word1 | word2 | word 3 etc.)
  3. It should replace all of the words

Its a nice idea.

Ideally though it would be useful to have instances where we can type input text and then set the output text to be replaced by on a case-by-case basis, which is unique. The method you’d describe would only work on replacing all text with a single replace. Appreciate the suggestion though.

Hi Luke,

I think I’ve come up with a plugin that’d do what you’re talking about. Take a look and let me know. I currently have it as a element upfront, and I’m debating if I should take the functionality into the workflow tab or the backend.


Hey Ziyad,

Nice work. Yeah, for sure, would be super handy to have this in the backend so it can be run server-side.

I’ve found a few quirks, I’ll PM you with the details.


1 Like

Nice plug-in @ziyad.elbaz :call_me_hand:

Agree with @luke2. I feel this would greatly expand the potential usecases for your plugin if it had server-side capability.

Not the end of the world using chaining in BEWF - just not overly elegant.


1 Like

The ultimate toolkit plugin has a server side action that does exactly that.

@AliFarahat how do you do that?

Hey Ziyad, thanks a lot for this plugin. It’s working like a charm.

Just noticed that it throws an error in the console on load (I think it’s if the source of one of the parameter is dynamic).

I’ve tried to delay or condition the visibility of the element, but I keep getting that error. Not a huge deal, as everything works fine, but just thought I’d flag it.

The plugin Missing plugin / element Find & Replace Input threw the following error: TypeError: Cannot read property 'split' of null
    at eval (PLUGIN_Missing-plugin-update--Find---Replace-Input-.js:3:15)
    at (please report this to the plugin author)


The plugin Missing plugin / element Find & Replace Input threw the following error: TypeError: Cannot read property 'replaceAll' of null
    at eval (PLUGIN_Missing-plugin-update--Find---Replace-Input-.js:3:86)
    at (please report this to the plugin author)

It happens to me as well with no dynamic parameter.

Hey yall! Thanks for the feedback and input. I’ve been MIA for the past couple of months but now getting back into the swing of things. I’ll try to push out an update in the next couple of days that addresses:

  1. those error logs @Lucien brought up and
  2. get some server-side functionality going.

Stay tuned!




Hello all !
Is it me or the chained find&replace doesn’t even work ?
The first one is applied, and then the following seem to be ignored…
I had to chain my workflow steps, gradually replacing characters along the way. Super frustrating, inefficient, and prone to errors.
Do any of you has had the same problem, and/or a solution ?

when I do ‘,’, it won’t remove the /

Did you ever figure this out? The chained find&replace used to work for me but now it doesn’t.

Well, I use multiple workflows, each doing a part of the clean.
I’ll probably write a plugin though (one day), would be way more efficient; and way less prone to errors.

1 Like

I’m trying this plugin, and I think it is the best implementation for find and replace. But I have a bug, if the values in the text I want to find is more than one. (For example I want to replace [abcd] two times in the text with (1234)). It only replaces the first one, the second variable [abcd] is not replaced.

Is this a known bug? any workarounds for it?