Forum Academy Marketplace Showcase Pricing Features

Generate new API token doesn't work in Live version

Hi everyone!

I’m trying to generate an API token to make an API request as admin, but I can only do so in development mode, i.e. not in live mode. The token that is generated in dev mode doesn’t work when I send a request to my deployed app. Has anyone run into the same issue ? thanks!

Hi @martinlenweiter :wave:

Yeah…

This is probably because your webhook link, the one you placed in your API, has a “version-test” in it’s URL. This means that the POST is being sent to your development version. You need to delete this part of your webhook URL.

1 Like

Hi @rpetribu and thanks for your reply ! But I don’t think that’s the problem, I sent the request to the live URL. The problem is that when I press the button ’ Generate a new API token’ in the API settings, nothing happens. Seems like a bug to me.

Cheers

Are you talking about this option?

If so… you can only generate a token in development mode. The token generated in development mode work in live mode as well. You need to generate the token and deploy the current version of you App to live.

1 Like

yes exactly. Okay, well then the problem is somewhere else, I will find it. Thanks a lot !!

Nawl, just deploy your app to live and make sure your endpoint doesn’t have /version-test/ in it