Generate Swagger Documentation -

I am trying to access my app’s swagger documentation for workflows as well as data objects.

We have a custom domain, three environments (dev, sandbox, and live), and one other collaborator with access.

This is for a client who wants to bang away at the app in sandbox before committing.

I am use to seeing this:

I have been though the different help topics, but I can’t seem to find an answer. Have been involved in this for a few hours and I am sure that someone might be able to drop some knowledge pretty easily.

$20 for the right answer via paypal. $100 via paypal if you would walk me through it. Calendly - John Casano


Given you have data and wf enabled in your API settings:

File > Import URL > Enter URL > Ok

Should generate everything you need.

1 Like


So, the swagger description does no more exist, right ? Either the doc has to be updated, either the feature has to be back :wink:

I waaaaant my swagger description ! :slight_smile:


Don’t forget to enable Data API.


Ankur@ Nocodetalks
Looking for a Bubble Coach? Check out here

Hu @ankur1, yes, indeed for the url, but I tried with both the bubbleapps domain and the custom domain, and I get a 401 error. All is enabled, swagger, data api,…

Weird !

Here after the 404 (not 401l error message I get for both test and prod, and I’m on a paid plan :

{“statusCode”:404,“body”:{“status”:“NOT_FOUND”,“message”:“Not found”}}

Would you mind sharing your app id? @Christophe_HK

1 Like

@ankur1 yes, done (PM)

I’d been wanting to build a Swagger UI plugin for a while.

Ya’ll inspired me to spin this up real quick: Swagger UI Plugin | Bubble

Let me know what you think!


I’ll give a try, thanks @brian9 !

hi @brian9 , I just tried out your plugin but it’s not defaulting properly to the app’s swagger JSON file. When I load my test page, it just says " No API definition provided." I have the Data API enabled and “Hide Swagger API documentation access” is not selected in settings.

It looks like your example page has the same issue: Plaid Link| Lost Sheep Advisory
How should I configure the plugin so that it always points to the most up-to-date API documentation for the current branch?

Thanks for pinging me on that - looks like there was a bug introduced somewhere. I just pushed a fix that should resolve that, if you update the plugin to the most recent version.

1 Like

Thanks @lostsheep , it works now after the plugin update :tada: