Forum Academy Marketplace Showcase Pricing Features

Geographic searchBox not registering input

I think the issue is with selecting the geographic results that are shown. It seems to not register as a valid input.

  1. I set a condition where the text of the SearchBox text is red when the value is empty.
    Screen Shot 2021-07-01 at 4.53.38 PM

  2. I start typing. The text isn’t considered a geographically valid input.

  3. I click(or press enter) on the highlighted location which i assumes makes the Geographic SearchBox valid. But the text is still red - the SearchBox’s value is considered empty.

  4. the address is only valid if the I space and click outside of the input. Which is not something any user is going to do.

Is this a known issue or am I doing something wrong?

Hi @brandon6 - Yes, this seems to be a weird bug. I tried the same and I could see that by removing a comma, it becomes valid.

If you notice in the picture, I had just removed “,” next to Los Angeles, and the input becomes valid or non-empty. This is true for many examples I tried, though the comma that needs to be removed is not predictable.

Search_Box_Error

You can check this on your side as well and open a bug report accordingly.

1 Like

Thanks for the response. I see, didn’t notice that. Will go ahead and create a bug report.