Get Call Not Working And Field Name Matches Perfectly

I’m using a GET call constraint and I can’t understand why I keep getting the following error when I check with Postman and the response field is accurate:

  1. {statusCode: 404,…}

  2. body:{status: “NOT_FOUND”, message: “Field not found app_shopping_cart_id for type shoppingcartitem”}

1. message:"Field not found app_shopping_cart_id for type shoppingcartitem"
2. status:"NOT_FOUND"
  1. statusCode:404

And in post man, the field looks like:

“app_shopping_cart_id_text”: “1517864030154x508368600206671900”,

I have tried to add the “_text” at the end to check but it totally crashes what i’m trying to build so I don’t think it’s that.

Importantly, the actual field i set up in Bubble is a text " App_shopping cart ID" - this too i have tried, with and without the _ and also all lower case letters and also as-is but it too won’t fire for some reason in the get call.

Is this in the Bubble SQL connector?

No it’s a mobile app.

In Bubble? Dropsource? Something else? Not really enough information here.

Dropsource, that’s the dropsource error when testing the app in the browser-emulator.

…and the Privacy tab for the table in Bubble should allow?

Yep, all setup correct there.

Did you double check that you are forming your request in such a way that allows Bubble to play nicely with Dropsource? For searches with constraints Add the Initialize Bubble API Constraints Action. - there is a page on Dropsource that has all this info… not sure if you have seen that?

Yes many other get calls worked within the app and each have constraints.of some kind so the communication is working I just don’t know why i can’t get the field to match resulting in an error when it looks spot on to me.

  1. message:“Field not found app_shopping_cart_id for type shoppingcartitem”
  2. status:“NOT_FOUND”

‘App_shopping cart ID’ is the field in Bubble? Have you tried re-making that table with a name that does not include spaces? What happens when you run ‘App_shopping cart ID’ as the param in Postman?

This topic was automatically closed after 70 days. New replies are no longer allowed.