Forum Academy Marketplace Showcase Pricing Features

Not Found Message when trying to Configure Bubble API for GET requests

Continuing the discussion from Connecting Zapier TO Bubble API:

I found this post as a reference for the Bubble API.

I’m trying to retrieve data from google sheets, using their IMPORTDATA command.
I set up my API for GET/Data for the Auction Type table:

But in Google Sheets I get the message:
Resource at url not found.

If I paste the authenticated string right into my browser address bar

the result is:

{“statusCode”:404,“body”:"{\n “status”: “NOT_FOUND”,\n “message”: “This application does not expose a GET/Data API”\n}"}

What am I missing?



That looks like it is doing a GET on the Donors data type. Not the Auction Type.

Also, is this live or dev. If dev it needs to look like …

1 Like

You’re right. I switched the types from donor to auction type, but had the old link in my clipboard.
The same issue occurs with donors, when I make the object type “donors”.

The link I’m using to return data from the “Auction Type” thing from the test app is:

Not sure how to format the object name with spaces in it. Would it be “auctiontype” or “auction_type”?

When I run it in Postman I get …

So I wonder if the issues is doing it from the Browser ?

Where did “apitoken-authtype” come from ? Is that bubble generated ? Using the standard bubble auth param I can GETs to work.

Yes, the “apitoken-auctype” is the label that I gave to the private token in the Bubble settings.
What’s the standard bubble auth param?

You don’t need to put the name of the key, it’s just for you. the standard URL is api_token=XX

Thanks for the clarification.

Using this string,

I’m still getting this message:
{“statusCode”:401,“message”:“Invalid or expired token: 1c96d659f1740b23d937b6be1443b296”}

I’ve regenerated the token, from the one I’ve posted here, but the error is the same.

It’s a version issue. The token you’re using is for development mode, and the URL is in live mode. You haven’t created a token in live mode. Also, it’s donor, not donorS.

This will work:


Wonderful, thank you!