Getting error 403 when trying to :saved to S3

I’ve got a public API that takes in a list of URLs and tries to save to Bubble with :saved to S3. Some images are saved properly, others error out with error 403.

Any clues on what’s happening here / how to solve it? Is there a way to catch unhandled errors like this in an API workflow?

@rico.trevisan hi! did you manage to resolve this? I’m facing the same error!

Probably an error with the target link that probably have a security on the file.
If you open the url in a private window, are you able to access it?

Yeah I thought it’s some kind of permission issue, but I can open the url in a private window or any browser. So it should be publicly accessible? really strange…

I guess too. But it could be permission issue of a different kind… It’s hard to know. Maybe in browser console log and network tab you can get more info about this error (code 403)

Thanks yeah it seems like it. I created a Get Image call on the API connector with key being the URL. I could retrieve publicly available images from other URLs but not this URL.

I get this error.

There was an issue setting up your call.

Raw response for the API
Status code 403

Just a moment...
Enable JavaScript and cookies to continue
(function(){window._cf_chl_opt={cvId: '2',cZone: '',cType: 'managed',cNounce: '28322',cRay: '7f7ada0a5ccdc361',cHash: 'be3889b933bdcf3',cUPMDTk: "\/5eeb4f9b-63a3-4fd5-af14-dab4950b08e9\/0_0.png?__cf_chl_tk=kx8oj.urPaMFqiVUtC2vY2AnmqQiRPG4uAVS.LnE8ok-1692201222-0-gaNycGzNC9A",cFPWv: 'b',cTTimeMs: '1000',cMTimeMs: '0',cTplV: 5,cTplB: 'cf',cK: "",fa: "/5eeb4f9b-63a3-4fd5-af14-dab4950b08e9/0_0.png?__cf_chl_f_tk=kx8oj.urPaMFqiVUtC2vY2AnmqQiRPG4uAVS.LnE8ok-1692201222-0-gaNycGzNC9A",md: "3O9wgy8NDscIhoxwdoYD51f6nevJjI40i17uwT9Zw58-1692201222-0-AQQCZqMo9tGmoOG1ir1gsyIYrXAD-v9jU_uHzItm8HIDaTx_LKGy-QmldzxXIguLTifpKVUmBFW_YegKfAtGpsCfhT7hiBjZD- (truncated as it's all hashed)

Crap, I forgot to report here my solution. I think there were 2 things:

  • I was not using the correct branch 🤦
  • the API Workflow didn’t have the ignore privacy rules option checked