Giving a full list a fixed height


My goal:
On page load, load an entire list which is scrollable. (fixed height)

My issue:
“Vertical Scroll” only loads the first few things and then loads more as you scroll…which is not my intent.
I want the FULL list to be loaded at once.

And “Full List” does not have a fixed height

My question:
Is there anyway to give a “Full List” a fixed height?
Is there anyway to load a “Vertical Scroll” list 100% initially?

Any help is much appreciated

1 Like

What is the main reason for loading the entire list? Speed/lagging issues? being able to “control” the UX via workflows? controlling the UI (already noted in your question)? capacity/data transfer impact?

Not questioning your intent/design at all, just trying to understand a bit more specifically what result you’re trying to achieve (or avoid) in order to try to find a viable solution…

Would this suit your use case?

Forget about the repeating group.
Use a multi-line input instead.
Set its data source the same search as you had in the full list repeating group, except:
append :join with to that search value, then type “line_break” (with no quotes).

Note: this definitely works with simple lists, like say individual texts, numbers, etc. Won’t have benefit of complex formatting like repeating group cells offer.

My main intent is just to give the impression to the user that once the page is fully loaded, it is fully loaded. i have groups and all sorts of workflows enabled from this list, it’s decently interactive so yeah the multi line input would work :frowning:

I found a work around but its causing limiting me in one other area which i’ll explain in a bit…

In order to get a full list loaded with a fixed height I put my RG which is set to ‘Full List’ inside of another RG which is set to ‘Vertical scroll’.
The trick is this:
I set the ‘Vertical Scroll’ RG to have only 1 cell, and have it display practically any field converted to a list’s First Item.
If I dont send any data to that ‘Vertical Scroll’ RG then my first cell containing the ‘Full List’ wont get rendered’

I figured this out accidentally (long and boring story) BUT this is causing me an issue elsewhere.

What I’m not trying to do is load two of these mega lists on the page. One is loaded by default and the other one is hidden until revealed via a workflow.
The issue is that my two lists have several more lists within it… the way they look as they load is unappealing… SO i figure: ‘why dont i just hide them until they are fully loaded’… Great idea!
Now here is when we run into issues. I cant find a way to identify when the list is fully loaded.

And this is when i starting wondering if there was anyway to avoid my workaround

You can “hide” a full list by putting it in a popup like this. Then maybe refer to that fully/loaded “source” by making your visible repeating group based on a list of numbers as described on this post/video (which could also be inside cell 1 of your scrolling group. Its the only way I know to avoid “double” loading, maybe there’s another way I don’t know. Not in front of computer at moment.

Explore this method

However, once you start hiding or putting a repeating group within another, the way it loads may change, ie, it may load in one slug rather than two. That example worked with one visible full list repeating group on initial page load.