Google Maps Error: "Oops! Something went wrong. This page didn't load Google Maps correctly. See the JavaScript console for technical details."

My app is throwing this error. I have read all the threads that pertain to this issue, checked to make sure all 5 APIs are enabled, my client and server keys in Settings are there. What else could be causing this?

Link to my editor: Project Gallery

It looks to me like you’ve restricted the use of your Google Maps API Keys to specific sites (you should do this) but in the process haven’t added this site to the whitelist.


Josh @ Support Dept
Helping no-code founders get unstuck fast :rocket:save hours, & ship faster with an expert :man_technologist: on-demand

Hey Josh! So, I restricted it to my domain and also to the bubble test version of my domain, but that’s it - did I do that wrong? How do I add the site to the whitelist? Thanks!

Have you added the full URL?

You have a couple of options:

  1. Add a wildcard which will be like this: domain.com/*
  2. Add the full URL which will be like this for test: domain.com/version-test/page

If you just include domain.com/version-test but then try to use this from a page other than the index page it’ll probably fail


Josh @ Support Dept
Helping no-code founders get unstuck fast :rocket:save hours, & ship faster with an expert :man_technologist: on-demand

This is how they’re listed. I think I did it correctly.
image

I’m a bit stumped, sorry. Without having access and some time to review it, I’m not sure how to steer you in the right direction. Perhaps Bubble support can help?


Josh @ Support Dept
Helping no-code founders get unstuck fast :rocket:save hours, & ship faster with an expert :man_technologist: on-demand

I post daily about no-code and Bubble on Twitter Follow Support Dept on Twitter

Im having the same issue. Seems like evertyhings ok in the console. but google maps not showing. Was doing a demo to a potential customer the other day, and looked really silly since it didn’t work.

Having this issue now anyone ever figure this out?

Just had this same issue, went back into the google console and made sure the client key address was in https:// format as previously it was just sitename.bubbleapps.io. Make sure you’re adding the https:// or http:// before your domain