Google Maps & Geographic Places

I recently noticed an search box designed to take in Geographic places data (which I’ve used for years), stopped working on an app (on a Personal Plan) I’m working on.

After some sniffing in the forum, I cam across this thread and as I understand it, this feature only works with the free plan…unless you get your own Google API for your paid plan.

Is this the case? If so, I still seem to be having challenges.

I have

  1. Created my own API, and
  2. I have linked the API to a billing account

Yet it still doesn’t work. Please note a copy of the app in 'Hobby" mode works perfectly.

Is there anything else that needs to be done? Please help

By stopped working, I take it you mean that when the user types in a value, nothing appears in the dropdown results list?

Make sure that you have all of the Google Maps APIs enabled (especially the Places APIs, not just the Maps APIs). That’s usually the source of the issue. Here’s a tutorial on setting it up.


Hell @dan1

Thanks for responding…and yes, your assumption about “stopped working” is what I’m experiencing.

I did go through the video and recreated new Map API keys; yet I’m still having the same problem.

The search box still isn’t working and other places where I’m using Maps seem to give me a Javascript error


Any idea what this issue might be?

Typically the Javascript error shows up when you haven’t selected the Javascript APIs. When you created your API key(s), did you select all of the APIs Google offers or just a selection of them?

To my immediate knowledge, as long as you’re not sharing your API keys anywhere where they could be used by someone else, you should be OK to enable all the Google APIs for Maps, Routes and Places at the same time. (You’re only billed for usage, not for having an API active). (As well, happy to hear input from others if they have opinions on enabling them all at once).

This was what I ran into and Places API was the key!


Yeah, I finally figured it out and I had the Places API disabled for some reason. It’s fixed now

Hi Dan,

You were right about that. Thanks. i got it working now

1 Like

I have a feeling it is disabled by default and you have to turn it on. I’m not looking at that page now, but if memory serves, Places was under and different tab. Glad it’s working again!