Forum Academy Marketplace Showcase Pricing Features

Google search results showing ":index"

Hi!

When Google shows my website as part of it’s search results, it shows all of the information correctly, except for next to my page title it adds “:Index.”

Is there a way to fix that so that it removes that part in the page results?

Hello!

You can try messing with the SEO tags and anything in that category. That is everything that will show up in searches. You must be on a certain plan to use these. Let me know if it works or you have any questions.

Sincerely,
Nathan

Thanks, Nathan!

I looked in there and it’s clean, no “index”

Any other ideas?

Thanks!
-Matt

Hmm. It shows the hoem page. As the default page is “index”. So It is showing the home page name. But I dont know how to fix that. You could try deleting all the SEO and publish and see if it goes away. The if it did put it back and see what happens. Hope you get what I mean.

Sincerely,
Nathan

Thanks, Nathan.

I enabled “Point URLs to primary domain for better SEO.” Not sure if that affects it.

I’ve discovered that the problem is only with Google, which is odd. Bing, Qwant and others pull it up properly (without “index”)

I’ll see if it self-corrects soon, if not I’ll delete all the SEO info and see what happens.

Thanks again, and if anyone else has thoughts, I would love to hear them!

-Matt

1 Like