GraphQL mutation works in API Connector but fails in Workflow

This API works correctly when Initialized in the API Connector.

I get the error below when I run the API from a workflow.

Can you help me debug this?

Does it have to do with how I am passing the two arrays of strings? ( & ) Or something else?

The API Connect config: Image 2023-03-12 at 3.24.33 PM
API call in Workflow: Image 2023-03-12 at 3.23.23 PM
The return results & error: Image 2023-03-12 at 3.26.27 PM
Image 2023-03-12 at 3.27.22 PM

The problem is probably with swapRecordIds and addOnIds.
In the test call you are sending an array as dynammic value for both parameters, but in the workflow you are just sending a string.
In bubble when you have a list of things and you put each item's something in a text field you get a string with the values separated by a coma. Just a single string.
Instead, you need an array in valid json format. You may want to use the format as operator to do that (see here for docs).

@dorilama Thank you so much! You suggestion fixed it.

Like this:

I may move the brackets into the JSON body in API Connector.

1 Like