Forum Academy Marketplace Showcase Pricing Features

Help Connecting UBER API

Hi guys,

I need help from API experts out there on how to connect to the Uber API properly.

Is it GET? POST? Other form of API call that I am supposed to be using?

https://developer.uber.com/docs/ride-requests/tutorials/deep-links/pickup

Hey @JustinC - you can see the Uber API implemented on our widgets site: https://widgets.airdev.co/apiwidget/1475192334739x482986778522026000

1 Like

@JustinC - I have made a posting on this.

I have got it to work part of the way, am getting some errors at the last step.

@vlad Any ideas on what is going wrong? Any help would be much appreciated !

@madras @JustinC
Did u follow the instructions (button on top-right corner) mentioned on the link that vlad posted ? If the error still pops up, let us know.

I’m not trying to integrate SSO.

I’m trying to integrate a deep link as referenced in the intial post.

@gaurav

Perfect!

I reviewed your examples and the documentation.

Worked like a charm. :smile:

The only issue I had was configuring the Uber Redirect URL. I had to cycle through some URL’s before it worked.

Thanks!

1 Like

Were you able to make it work with multiple scopes?

Yes.

You need to define the different scopes in the in the initial OAuth request

That’s the crazy part. I read in the documentation that the scopes were space delineated. Is that how you set it up? I can get the token with just one scope defined. Not multiple.

https://developer.uber.com/docs/trip-experiences/references/api/v2/authorize-get

I’ve set the scopes in the Uber dashboard

And the Bubble info.

Did you include the scope in each call? I haven’t done that.

That would be correct. Scopes are usually separated by space, not just for uber but also most apps

I’m getting this error. is this a bubble thing?

solution:

Put the scopes in a specific order where the PROFILE scope is last.
Uber doesn’t specify that in their documentation. :confused: