Help troubleshoot this WF on a List

This was working last week, now it’s not. When it started throwing errors, I rebuilt it by following along Bubble Webinar 4 and many other sources. From viewing the log, I think the trouble is in the backend workflow, but I don’t see what’s wrong. I’d be grateful for any help.

This workflow is meant to send a text to all users whose role is Subscriber. There are two data types involved: 1) User and 2) SMS Topics. There are only a few entries in each, so volume is not the problem.

Here are screenshots:
BACKEND:


image
PAGE:
image

LOG:

Make sure that the recipient’s phone number doesn’t have any parentheses, hyphens and only includes the area code and phone number in the following format: 1234567890

There aren’t any. They’re numbers only.

Hmm… funny question to ask, but are you on the free trial of Twilio?

Nope, paying customer. And I’m on the paying plan for Bubble, too, Please keep trying, I appreciate your help!

Have you checked your privacy settings to make sure the user initiating the request has permissions?

That’s something I hadn’t remembered to check, so thank you! Unfortunately, I just removed the privacy settings but am still not getting any messages and the log results look the same.

Hmm… have you double checked that your SMS type is not empty?

Have you checked that your recipient number is the same as the one in Twilio?

Yes and yes

Just to see if the plugin is working or not, have you tried to send a text to yourself without any dynamic data?

Yes. And it worked fine.

And it also worked with dynamic SMS content.

Hmm… within the server log do you see any errors that it threw?

I don’t see any errors. The ‘list to run’ on matches the unique IDs of the users. The sms ID is correct. The date is correct. It all looks good, as far as I can tell:

Did you try to zoom into the Schedule API workflow action?

Do you mean Server Logs > Zoom in on This Workflow? That returns a blank screen. Is there another way to look at the backend workflow’s processes?

NM, it doesn’t return a blank screen
It just returns a screen exactly like the screen I clicked away from – the one I posted above.

Hmm… this is so strange @J805 tapping you in, do you have any clue what’s going on here?

I’m not sure if I’m glad the problem isn’t some dumb mistake on my part or sad the problem isn’t some dumb mistake on my part. At least dumb mistakes are easy to fix.

Have you tried to hit the “Ignore Privacy Rules” button on the API workflow?