Help with Google API Conector

Guys, I need a helping hand with google api
I’ve configured the bubble api conector like this:

But i keep getting this error when i try to login on workflow:
(the worflow of the button to login into the api)
(the error after login and authorize google)

It’s been 3 days trying to solve it and I don’t know what else to do, can you guys help me to figure out a solution? Thks

The setup in the API Connector looks wrong to me (been a while since I connected to GA). Why don’t you start by copying the way this plugin has set everything up (because I know this plugin works) Extended Google Analytics Plugin | Bubble

1 Like

I already tried this one, but i get a bunch of errors too :frowning:

You shouldn’t do. What error messages do you get exactly?

1 Like

Forgot. I mocked up access to GA for someone the other week.
Follow this setup Google-analytics-api | Bubble Editor

1 Like

Seems to work properly, but i get the same error above :sob:
(also your button workflow is empty so i keep using my workflow above)

OK so that should mean the Bubble side of things is good. So the problem probably lies with your settings.

Do you have your redirect URI set correctly I.e. to this URL?

1 Like

So cool to know that the bubble side os ok!
but I just added this domain, I did a test and I still have that error…

Crossed wires - what I meant was you need to add the URL I circled to your authorised URIs list i.e. this one

You can remove the two, https://google-analytics-api.bubbleapps

1 Like

oh, ok, got it now :grinning_face_with_smiling_eyes:
i’ve added that uri:
but that error still appearing :frowning:

I don’t know what, but you’ve obviously got something setup wrong, either in Bubble or If you want to DM me, I’m happy to jump on a Zoom call with you to go through it and work out what is wrong (I’m on UK time).

1 Like

omg, of course that i accept!
but only if you don’t mind my brazilian not to good english… :sweat_smile:

We’ll cope :slight_smile:

1 Like