How do I stop the search bar from making duplicates

hello fellow bubblers,

how do I stop this from happening, I have been trying for few days. every thing else works only the search bar is giving me a headache.

the goal is that so the user can view only those data that he is interested in. Some may not wish to see every thing

Can you explain the problem a bit more? I don’t quite understand.

Hi there, when I use the search bar, to search ID or asset type, or and other field, the RG displays the data in duplicates. is there a better way to display the needed data?


Simple solution = add “:unique” to the end of your data source.

1 Like

dear sir, unique id or unique elements ?

I’ve always seen it displayed as “:unique” - it makes it so that the list of things is unique (no thing is included twice).

Is this what you mean? Or I’m I doing something wrong ?

That’s probably it. I’ve never seen “:unique elements” as an option before. It looks like Bubble must have changed “:unique” to “:unique elements” recently and I’m not seeing it because I’m on a slightly older version on our dedicated server.

Either way, give it a try and let me know whether it works.

1 Like

Hi there , thanks for your input. Helped me to solve the issue. But it wasn’t with :unique elements, instead I used :filtered , haha would not have seen the filtered without looking for unique

1 Like