How to do faster searches

I’m implementing a similar functionality to the Searchbox function that’s native to Bubble, but it’s so slow!

I have an input textbox and a repeating group below it that lists results based on a lowercase “contains” search (I store this separately in my DB because Bubble doesn’t have a case-insensitive search feature), like so:


When I type, it takes about 1 - 2 seconds after I stop typing for the repeating group to update. Is there a way to speed this up? I don’t think this is a db speed issue because 1) I only have a few dozen records at this point and 2) the Search Box feature shows results immediately. So, is this a matter of getting the repeating group to update faster?

How do I make my results as fast as the Search Box results?

1 Like

Hi @johndurso

you might want to try and experiment with this plugin: Instant text Plugin | Bubble. This will help with the starting delay.



Hi @Guru
You can try ZQ Fuzzy Search & Autocomplete Plugin for Bubble Plugin
It’s very fast
Please have a look at the demo

Here is the link to bubble editor.

ZQ’s Fuzzy Search does work but do take note that it does struggle with large records and will slow down your page if not done right.

It’s awesome but takes a good setup if you are trying to filter through large data.

1 Like

That’s good to know, what constitutes good setup?

It works better with lighter data (less fields) since the plugin loads every record in your data source.

A good workaround i found in my CRM was to have Fuzzy search through a state’s list of text containing just the search parameter (eg. Full Name) and I’ll point my RG’s data source’s constraint/advanced filter to the plugin’s result (eg. Full Name is in Result)

I’ve since built a simple but performant search workflow for my CRM but I suggest trying the plugin first!

Hello @johndurso

Try using “contains keywords” instead of “contains”

1 Like

@cmarchan - I don’t think that would work for my use case, because I want potential search results to pop up before a word is complete, much like the Search Box functionality does. “Contains keywords” only works with whole words.

@ihsanzainal84 thanks, I’ll try that with the workaround.

This topic was automatically closed after 70 days. New replies are no longer allowed.