How to remove "/index" from url?

Hi :raised_hand:t2:, I built a single page web. As usual I am using the “go to index page” workflow + arbitrary text as my web page navigation function.

I like its ability that enable users to press the back button on their browser. However I found my url directed to"arbitrary-text"


Is it possible to remove “/index” from my url?
*I’ve also made sure my page doesn’t have type of content

Maybe you can use Cloudflare to rewrite the URL?

Usually /index is removed by Bubble if you don’t have anything on the page. But in this case you do. Maybe use a parameter instead?

Hi sir :raised_hand:t2:, it’s such an honor for me to be responded by you.
Some of your post helps me a lot in the past. :raised_hands:t2:

Well, I don’t like parameter cause it’s not SEO Friendly. Today I decided to change my web into multiple page as it seems more easy for me to control how the URL looks.

But I have one question, does url rewrite helps SPA’s SEO?
If it does, then I think I will definitely learn about it.


is that the real index or you created the page named index?
because the first page name index, the “index” text will not appeared on Url unless you “make change in to page index” and that page will replace to index by right clicking the page

Hi :raised_hand:t2:

Thank you for your response. Yes, the page is the actual index. Bubble said its not bug or whatsoever, it happens by design.

This topic was automatically closed after 70 days. New replies are no longer allowed.