How to rename files when saved to S3

Will you file a bug report and report back your findings? I told them they need to put a clarification and tutorial into their documentation. They said they’d get around to it as soon as they can. So whenever that will happen. :roll_eyes: LOL

I’m also trying to figure out how to rename images that are generated by external API.

I’ve tried the saved to s3 and changing the file name, but the image is still saved with all these ugly parameters at the end of the URL.

Anyone figure this out? Pulling my hair out over here on this.

Also just filed a bug report about it.

Anyone figure this one out?
No hair to pull out


It was working fine, when saving files from External Domain. But it cannot work if file is already in bubble s3.

Please refer Documentation : Operators & Comparisons - Bubble Docs

I have tried to save image from external to bubble s3 and used renaming of file also working,
Demo : Your Bubble app

Hi all ! any solution ? struggling on this one as well ^^

Hey guys! I am reviving this old thread because I have released a free plugin that lets users rename files before sending them to S3 (the bubble servers). It is called Better Uploader.

You can find the forum post here or you can visit the plugin page:


Bookmarked @jonah.deleseleuc ! Thanks!

1 Like

You’re welcome :slight_smile:

Any update on this? receiving the file from an API call

The file name doesn’t seem to be changing when using the save to s3

Also, when changing the file name, the URL is being changed to be the same

This is getting very frustrating

Bump…Any solution on this?

Saved to s3 will sometimes allow you to rename the file but not always. I have built a plugin that allow you to rename a file (this will create a new file with the new name. You can delete the previously saved file after)

1 Like

Thx. Can i use this plugin when i receive data from an API?

This was built originally exactly for this case :wink:

Is this the correct workflow?



Can you try to add https: before url?

Like a bomb :muscle::+1:
Thanks Jici

1 Like

Hitting the same issue as @thinus1 . I tried adding the https: before the dynamic Website home URL and just pasting the sites actual URL in.
Screenshot 2023-03-13 at 1.56.30 PM
Screenshot 2023-03-13 at 1.55.22 PM

https should be added before dynamic link, not before website url

1 Like

This plugin honestly works great. Is there a way you can add a “retain original file extension” option?