Ignore privacy rules - possible bug

Hi gang. Not sure if this is a bug or operator error on my part… I have a backend workflow where I log events. For example, when a not-yet-user (“prospect”) expresses interest in signing up. I have a logging config table where I have an active Y/N field governing whether or not to log capture of prospects.

During initial testing of the workflow, I was logged in with my admin/owner account and the logging events were appearing in the Db. However, when I tested while being logged out - as all prospects will be - the logging did NOT work.

I suspected privacy rules and so I checked “Ignore privacy rules” and still no dice. It didn’t work until I changed the privacy rule on my logging config table and specifically made the active Y/N/ field viewable to anyone.

Two questions:
1 - I see some old posts about this setting. What’s the current state of the union? Is there a known bug here or should I join the crowd of folks who have reported it?
2 - I’m calling my backend workflow from a frontend workflow. On the calling event (Schedule an API workflow), there’s a checkbox to Ignore Privacy Rules. Bubble also presents that same checkbox on the backend workflow definition. Why both spots? Which one wins? (I tried both and still no dice, but I’m curious about the 2 checkboxes.)


This topic was automatically closed after 14 days. New replies are no longer allowed.