I'm stuck on making my search feature

I am trying to make a search feature and I am following the loose guidelines on a tutorial. I am trying to be able to have my users search for a duck number by the duck ID #. For data sent I’m putting search for ducks and for the constraint I am putting in duck ID # = get search from url and putting in the parameter

. That should work but it’s not. When I click away I get an error message. I don’t know what I’m doing wrong. I have included a screenshot.

So I see 2 errors:

  1. Search_results page needs to be the type of “ducks” so on that “main” page change the content.
  2. Your “search for ducks” is going to return a list of ducks. I’m guessing you want a single duck. add “:First item” to the “search for ducks” yellow text above.

Goodluck with your ducking app!

1 Like

I changed the content to ducks for the search results page and added the :first item, but it still goes red and has an error. it says the thing should be ducks but right now it’s a list of ducks. I am confused. I don’t know what a list of ducks is or what i’m doing wrong. Maybe i’m not smart enough for Bubble.

woah woah you got this!

It’s probably still something about the :first Item
Should look like this?

What does the new error say?


This is so ducking hard. I made another app in the past that had a search feature and it worked well. I tried to duplicate it with this app but the other app didn’t make me have data to send. Here is my error message.

This topic was automatically closed after 70 days. New replies are no longer allowed.